Skip to main content

List of all our extensions

Create an account

ID conflict

ID conflict was created by keep2000

Posted 10 months 1 week ago #25
Hello
I'm not sure if it's a real-life problem but as JP VM Ajax Search uses $module->id for html tag ids and function names, it means I can use one module only once in a specific page, because it'll cause id conflict/duplicated function names.
Like the customer wants a search in the header and footer/sidebar.
Should I create multiple module instances in this case? If it's possible, I'd keep only one module.
I mean since YTP allows to add modules to the build without Joomla's module position, $module->id is not that hard, when you had to bind the module to a position which was displayed in a creartain point of the layout, it's much more flexible with YTP.
But again, it's maybe just me :)

This message contains confidential information
Last Edit:10 months 1 week ago by keep2000
Last edit: 10 months 1 week ago by keep2000.

Please Log in or Create an account to join the conversation.

Replied by joomlapro on topic ID conflict

Posted 10 months 1 week ago #29
Hi
We added your valuable suggestion to our plugin future road map and updated in our upcoming version release. Thank you,

For urgent help please create a support ticket extensions.joomlapro.com/support/tickets
The following user(s) said Thank You: keep2000

Please Log in or Create an account to join the conversation.

Replied by joomlapro on topic ID conflict

Posted 9 months 2 weeks ago #54
Hello

We have tested 2 modules with following position top and bottom.  It seems already working. if you have issue again, please create support tickets with site details. we will take a look.

Thanks

For urgent help please create a support ticket extensions.joomlapro.com/support/tickets

Please Log in or Create an account to join the conversation.

Time to create page: 0.746 seconds
Powered by Kunena Forum
Joomla 4.0 supported
6 months support & updates
6 months of access to support and downloads/updates. The extensions will keep working after this period.
Joomla 3.10 supported
Unlimited Websites
You can install all our extensions on as many websites as you like.
Wordpress version available
Custom Development
If you encounter any problems with your website that does not cover support we might offer you a custom quote to help you.
Look for these icons for available supported platforms:
Joomla 4.0 supported
Joomla® 5.x support
New Joomla® 5 supported!
Joomla 3.10 supported
Joomla® 3.x support
Joomla® 3.9 / 3.10 supported
Wordpress version available
Wordpress version
Alternative WP version available

Extension list

yootheme

ecommerce

joomla